ejabberd 13.12

We are pleased to announce a new stable release of ejabberd, ejabberd Community 13.12.

It has several bugfixes over the previous 13.10 release, and a few new features:

  • New OpenSSL ciphers option in c2s, s2s and s2s_out
  • mod_roster: new access rule to restrict roster modificartion
  • mod_pubsub: support for data migration from mnesia to odbc
  • ejabberd_xmlrpc included

As usual, the release is tagged in the Git source code repository on github

The source package and binary installers are available at ProcessOne

If you suspect you found a bug, search or fill a bug report in Jira

Please note this branch requires at least Erlang/OTP R15, and works correctly with R16B03.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

websocket support in 13.x version

Hi,

Does 13.x version supports websockets?? if yes can you please give some details about that.

Thanks,
Viswanath

rebar get-deps

Hi,

I've downloaded tar.gz and see that rebar gets deps from master at building. Because of this, depending on the day when I compile this release, I may get different result (someone pushed to processone/xml master, for instance). Why don't you pack all necessary sources into tar.gz? Or, stick rebar deps onto known commits for that particular ejabberd release.

not able to install ejabberd of any version

[root@dev50 ejabberd-13.12]# ./con
configure contrib/
[root@dev50 ejabberd-13.12]# ./configure
checking whether make sets $(MAKE)... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for a sed that does not truncate output... /bin/sed
checking for erl... /usr/local/bin/erl
checking for erlc... /usr/local/bin/erlc
checking for erl... /usr/local/bin/erl
checking for erlc... /usr/local/bin/erlc
checking Erlang/OTP version... conftest.erl: internal error in parse_module;
crash reason: {undef,[{epp,read_encoding,["conftest.erl"],[]},
{compile,parse_module,1,
[{file,"compile.erl"},{line,784}]},
{compile,'-internal_comp/4-anonymous-1-',2,
[{file,"compile.erl"},{line,277}]},
{compile,fold_comp,3,[{file,"compile.erl"},{line,295}]},
{compile,internal_comp,4,
[{file,"compile.erl"},{line,279}]},
{compile,'-do_compile/2-anonymous-0-',2,
[{file,"compile.erl"},{line,153}]}]}
configure: error: "Could not compile Erlang/OTP version check program using '/usr/local/bin/erlc'"

APT?

Hi, Are you planning to create a ppa for this version? I need it to integrate with puppet.

If not, please suggest a good way to integrate into puppet.

Thanks!

Syndicate content