ejabberd 15.07 has been released

This month’s ejabberd release contains many fixes and a few improvements. This is a consolidation release that help
us pave the way to exciting new features coming at end of the summer.

Since we released our Message Archive Management support in ejabberd 15.06, we have been impressed by how quickly our
users did adopt this features. It helps us make the implementation more robust and more complete, thanks to your
feedback. This release thus improves ejabberd mod_mam.

We have also been very happy by the feedback received on our brand new installer for Windows, and for the .deb and
.rpm packages. They are still beta, but thanks to your feedback, we could improve them tremendously. So, keep the
feedback coming !

And of course, all this work on installers help us improve our tool to deploy and build ejabberd contributed modules.
Contributed modules can now include their own configuration snippet, which are dynamically loaded by ejabberd.

Overall, this version should be easier and even more enjoyable to run and we all hope you will like the progress.


Message Archive Management (XEP-0313)

  • Add “complete” attribute to MAM final response
  • Fix mod_mam compatibility with RSM
  • Changed mam iq get to set as specified by XEP-0313 v0.3

Modules management

  • Ensure config snippet is loaded at module installation
  • Allow contribution to include .yml or .yaml config file
  • Allow include of simple dependencies

Multi User Chat

  • New API hook: muc_filter_packet
  • Send notifications on MUC configuration changes
  • Omit warning message regarding non-anonymous room
  • During halt only shutdown MUC rooms on local node


  • Allow migration of old pubsub items with old xmlelement structure in body
  • Trigger PEP notifications on CAPS updates
  • Check for node subscription of bare JID
  • Flat is now the default plugin

Stream Management (XEP-0198)

  • Increase timeout during resumption
  • Increase default “max_ack_queue” value

ejabberd Client connection

  • API change: user_send_packet is now a run_fold hook and pass the c2s State as a parameter. It was already the
    case in ejabberd 15.06, but it was not mentioned in the changelog, by mistake. So, now, you know :)


  • Do not rely on behaviour info when doing config validation, so that it can work with ejabberd binary installers
  • When passwords are scrammed, report check_password_hash cannot work
  • Fix problem with merging values from multiple config files
  • If local guide.html file not found, redirect to the online guide
  • Support RTL page direction in WebAdmin for Hebrew
  • configure.ac: add AC_CONFIG_MACRO_DIR and static AC_INIT


  • Don’t crash web admin when displaying info about websocket using users


  • Both RPM and DEB now are using the improved post-install script which creates ejabberd user when installing as
    root. This let ejabberd running as user without any manual setup.
  • Windows installer now uses %USERPROFILE% to get path of user writable directory. We made numerous other fixes
    to that version, thanks to your feedback.


As usual, the release is tagged in the Git source code repository on Github.

The source package and binary installers are available at ProcessOne.

If you suspect that you’ve found a bug, please search or fill a bug report on Github.

Hi, I am having following


I am having following issue while trying to install Ejabberd 15.07 on Ubuntu server. I have tried on two different machines. I have tried both with SU user and without SU user. I am tried searching on internet too but could not found any solution. Please see below logs and help me

./ejabberd_15.07-0_amd64.deb: line 1: syntax error near unexpected token `newline'
./ejabberd_15.07-0_amd64.deb: line 1: `!< arch >'

Please help me solving this issue.


Which Ubuntu version is it ?

Which Ubuntu version is it ?

mremond wrote: Which Ubuntu

mremond wrote:

Which Ubuntu version is it ?

Using 14.04 LTS

I created an issue report on

I created an issue report on Github for you: https://github.com/processone/ejabberd/issues/691

What you suggest me. How I

What you suggest me. How I can install server on my machine. Actually I have to setup a IM server and I am trying to install latest one. So please help me If I can install another installer or can you guys share older version of installer.

A ticket as been created. You

A ticket as been created. You should either install from source or wait for next installer version in 15.09.

Confirm same issue on Ubuntu

Confirm same issue on Ubuntu 14.04, will wait new version with this bug fixed.

Syndicate content