Versions of Ejabberd requiring GLIBC 2.14

Just a general complaint, there was no warning in the notes that newest releases are requiring GLIBC 2.14..

This excludes myself from all future updates, as Centos 6 is currently maxing GLIBC 2.12.

I don't understand the need to alienate anyone with an older system, must be a millenial thing. Please just go ahead and rewrite jabber in rust... Sorry, just frustrated. This should be in the notes somewhere, I may have missed it.

Ejabberd versions >= 17.08 require GLIBC 2.14 and SSL negotiation fails.

Right, I see no mention in

Right, I see no mention in the release notes
and the README.txt doesn't even mention that requirement.
In the main ejabberd souce code libc isn't mentioned, I guess it's required by some erlang required library included in ejabberd, and got unnoticed.

If that breaks SSL, then it may be the fast_tls library. You can try to use an older one. Or maybe STARTTLS?

Syndicate content