Solved: Unable to Register Users Remotely

I'm running ejabberd 17.07 on Debian 9. I am using PostgresSQL as the DBMS. In order to initialize the database, I used /usr/lib/x86_64-linux-gnu/ejabberd-17.07/priv/sql/lite.sql as a baseline. I made a copy called "plite.sql" and edited the MySQL syntax so that it fit with PostgresSQL syntax. I removed "INTEGER PRIMARY KEY AUTOINCREMENT" (which is not supported by psql) and exchanged it for "SERIAL PRIMARY KEY" as well as removed the "UNSIGNED" qualifier from the timestamp columns. Once I did this, I was able to initialize the database.

I'm able to manually register users by using this command:
ejabberdctl register foo Passw0rd

Once I register the user, I can successfully log in as the user and receive valid SSL certificates, so I know that my configuration is working up until that point. However, when I use a client such as coyim or pidgin, it does not allow me to register. I simply get these errors:

Registering a new user with pidgin:

17:25:12.195 [info] (<0.505.0>) Accepted connection ::ffff: -> ::ffff:
17:25:13.009 [info] (tls|<0.505.0>) Failed c2s PLAIN authentication for from ::ffff: Invalid username or password
17:25:13.164 [info] (tls|<0.505.0>) Failed c2s SCRAM-SHA-1 authentication for from ::ffff: Invalid username or password

From coyim, I get a different error:

17:25:47.894 [info] (<0.507.0>) Accepted connection ::ffff: -> ::ffff:
17:25:51.506 [info] (tls|<0.507.0>) Failed c2s SCRAM-SHA-1 authentication from ::ffff: Malformed or unexpected attribute

I fear that my configuration file is messed up. I've coped it to pastebin and removed/replaced any sensitive data. Please help:

Some notes: I'm using cloudflare for the domain with SRV records and pointing to the XMPP server. The A records point to the web server. I'm not sure if this is useful information or not.

Wait a second... I think I

Wait a second... I think I overlooked something important. The `mod_register` module is disabled on line 710. I will enable it and report back if it solved my issue.

Yes, it works now. Closing

Yes, it works now. Closing thread if possible.

Syndicate content